Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Internet Banking and Mobile Banking App currently unavailable
Incident Report for Standard Bank
Resolved
This incident has been resolved.
Posted Mar 25, 2022 - 08:45 CAT
Investigating
Standard Bank: We regret that you may not be able to login into Mobile Banking App and Internet Banking. We are working on resolving this urgently. Please use Cellphone Banking as an alternative by dialling *120*2345#. We apologise for the inconvenience.
Posted Mar 25, 2022 - 07:26 CAT
This incident affected: Internet Banking (Internet Banking Login, View Balances, Instant Money, Buy Airtime and Data, Buy Electricity, Play Lotto, Account Tiles, Banking Statements, Business Banking Statements, IT3b Certificates, Debit Order Reversal) and Mobile Banking (App Login, View Balances, Instant Money, Buy Airtime and Data, Buy Electricity, Play Lotto, Account Tiles, Banking statement, UCount, Business Banking Statements, IT3b Certificates, Add-ons Store, Debit Order Reversal).